Meerdere resultaten weergeven zonder verticaal zoeken

Verticaal zoeken is een functie waarmee je data kunt ophalen uit een specifieke kolom in een tabel. Het nadeel is dat de functie is bedoeld om 1 resultaat weer te geven. Soms kan het zijn dat je meerdere overeenkomsten in de tabel hebt die je wilt tonen. In deze uitleg gaan we meerdere resultaten  in één lijst verwerken. 

Hoewel ik in de titel van dit bericht de term verticaal zoeken gebruik komt de hele functie niet voor in dit artikel. De functie verticaal zoeken is genoemd omdat het resultaat lijkt op verticaal zoeken. Hoe de functie verticaal zoeken exact werkt kun je lezen in het artikel Excel verticaal zoeken functie

Adresboek

We beginnen met een simpele adresboek tabel. We zien in de tabel enkele gelijkenissen zoals 3 Marieke’s en 2 keer de achternaam Peters. Als we nu VERT.ZOEKEN op Marieke krijgen we alleen de gegevens van rij 2. Er is immers een resultaat en dus is de functie voltooid. 

Meerdere resultaten weergeven zonder verticaal zoeken

Nu willen we juist een lijst krijgen van alle Marieke’s als ik zoek op de voornaam Marieke. In de volgende afbeelding van het tabblad “Zoeken” zien we het eindresultaat. We zoeken op voornaam Marieke en krijgen 3 records. Op de achternaam Peters vinden we 2 records.

Meerdere resultaten weergeven zonder verticaal zoeken

Werking van de zoek functie voor meerdere resultaten

Buiten de namen, telefoonnummers en email adressen zien we op het tabblad Zoeken nog een hulp kolom met getallen. De getallen corresponderen met de rij nummers van de persoon in het adresboek. Dit doen we middels de volgende formule:

=VERGELIJKEN($B$4;VERSCHUIVING(TELEFOONBOEK!$B$1;F3;0;1000;1);0)+F3

Zodra we het rijnummer weten kunnen we middels de volgende INDEX formules de overige gegevens uit deze ophalen:

=ALS(ISFOUT(INDEX(TELEFOONBOEK!C:C;$F4));"";INDEX(TELEFOONBOEK!C:C;$F4)) // Achternaam

=ALS(ISFOUT(INDEX(TELEFOONBOEK!E:E;$F4));"";INDEX(TELEFOONBOEK!E:E;$F4)) // Telefoonnnummer

=ALS(ISFOUT(INDEX(TELEFOONBOEK!D:D;$F4));"";INDEX(TELEFOONBOEK!D:D;$F4)) // Email adres

Op dezelfde wijze werkt ook de lijst van de achternamen. 

Download voorbeeld bestand

  Telefoonlijst-verticaal-zoeken-meerdere-waarden.xlsx – Bestandsgrootte 19,9 Kb  

Theo Schipper

Dit vind je misschien ook leuk...

1 reactie

  1. Albert schreef:

    Beste Theo, jij bent mijn held want je hebt onze afdeling erg geholpen. Ik ben zelf docent/psycholoog en wilde het secretariaat helpen om in het universiteit/ziekenhuis waar ik werk 3000 lessen te plannen voor onze docenten via excel. ik heb veel aan je download voorbeeld bestand:"telefoonlijst-vertikaal-zoeken-meerdere-waarden" gehad! Deze heb ik gebruikt als basis en de verwijzingen "omgebouwd" naar ons rooster. Ipv een telefoonboek is het nu een opzoekfunctie geworden waar we de naam van de docent invullen en dan komen zijn of haar lessen te voorschijn. Dat scheelt ons veel tijd zodat we meer bij patiënten en studenten kunnen werken. Dus bedankt daarvoor!

    Nu had ik een vraag. Hopelijk kan ik het concreet genoeg uitleggen. Bij het bestand:download voorbeeld bestand:'telefoonlijst-vertikaal-zoeken-meerdere-waarden' en tabblad 'zoeken' cel F4 staat:
    =VERGELIJKEN($B$4;VERSCHUIVING(TELEFOONBOEK!$B$1;F3;0;1000;1);0)+F3. Dit zorgt ervoor dat excel in tabblad 'telefoonboek' de namen leest in kolom'B'. Stel ik heb verschillende namen in 6 kolommen naast elkaar. Dus bijvoorbeeld in kolom B, C, D,E, F en G. Hoe pas ik de formule aan zodat excel die de namen van die 6 kolommen uitleest? Je zou me erg bij helpen als je dit weet.

    ik had dit geprobeerd maar dat deed die niet(er staat nu 'rooster' ipv 'telefoonboek.' En ik heb:G$1$ toegevoegd.)
    =VERGELIJKEN($B$4;VERSCHUIVING(rooster!$B$1:$G$1;F3;0;1000;1);0)+F3

    Dank alvast!

Geef een antwoord

Het e-mailadres wordt niet gepubliceerd.